We are experiencing an outage in one of our upstream services.
Resolved
May 21, 2026 at 6:56pm UTC
We have received the green light from our upstream service that supports some key parts of our Voice AI services.
All Voice AI services have been re-enabled and back up and running.
All other CourseRev services have since been unaffected.
Affected services
Updated
May 21, 2026 at 3:31pm UTC
We have put in an automatic forward to all fallback/pro-shop numbers until we get an all clear from our upstream service providers.
Affected services
Created
May 21, 2026 at 2:34pm UTC
One of our upstream services is experiencing an outage which is causing call degradation.
All calls will forward to the pro-shop automatically as a fallback.
Please bear with us while we monitor the issue and reach out to our upstream our upstream service provider.
Affected services